“In primo piano” e altre funzionalità per Compiz: pacchetti

Aggiornamento: spostato l’archivio su un altro server, dovrebbe essere accessibile adesso.

Molte persone in passato hanno segnalato quello che è stato spesso erroneamente identificato come un bug in Compiz, ossia la perdita della funzione “In primo piano“. Ecco due immagini per chiarire:

libwnck01.png
Libwnck “liscio”: mancano alcune funzionalità ormai considerate essenziali

libwnck02.png
Libwnck con le nuove patch e un migliore supporto a Compiz. Ecco di nuovo le opzioni! :)

Beh il problema – come spiegato in varie occasioni – era in realtà di libwnck che non supportando alcune specifiche andava in tilt. Adesso sono state rilasciate alcune patch per sistemare la situazione. Le patch in tutto sono quattro, e re-introducono queste funzioni:

  • Tenere una finestra sopra tutte le altre, quindi utile per guardare la TV, come dice Hayabusa :D
  • Spostare la finestra ad un’altra faccia del cubo
  • Avere una finestra su tutte le facce del cubo
  • Un sottomenu “Appearance” che permette di modificare alcuni dettagli estetici come la trasparenza di ogni finestra. Questa non funziona, e non me ne può fregare di meno :)

Ecco qui le patch, potete anche non applicarle tutte. Visto che avevo 10min in più ho deciso di applicare le patch ai pacchetti debian e ricompilarli per supportare adeguatamente queste opzioni.

A questa pagina trovate un archivio con i pacchetti deb per Ubuntu Edgy da me compilati per pollycoke, una volta scompattato l’archivio dove volete voi potete installare i pacchetti come meglio preferite, e al prossimo avvio di Compiz avrete le nuove funzioni :)

Nota: Synaptic cercherà di riportare i pacchetti alla versione originale di Ubuntu. Per bloccare i pacchetti con Synaptic basta selezionarli e poi spuntare “Blocca versione“, dal menu “Pacchetto

24 pensieri su ““In primo piano” e altre funzionalità per Compiz: pacchetti

  1. Forse è un po’ ot: il mio problema è che quando attivo il GL desktop le finestre massimizzate vanno parzialmente sotto il pannello superiore… e le devo spostare manualmente. C’è modo di risolverlo? Grazie!

  2. Scusate la domanda un po’ stupida ?
    Ma come faccio una volta installati i 3 pacchetti deb a non farmi proporre continuamente di riaggiornarli (synaptics si accorge che non sono i pacchetti dei repo), ho provato a impostare “blocca versione” e “forza versione” ma non ho concluso niente.

    Ciao.

  3. Mi dispiace ma come dicevo nel precedente post anche se imposto “blocca versione” mi viene sempre proposto di aggiornare i pacchetti.
    Ho provato a dare “blocca versione” sia prima che dopo l’installazione dei nuovi pacchetti ma l’esito è sempre negativo :-((

  4. @kaiowas:
    Le patch vanno applicate ai sorgenti di Compiz. Se non sai come fare e hai Ubuntu Edgy puoi sempre usare i pacchetti belli pronti, altrimenti… c’è da studiare :)

    $: man patch

  5. Domanda stupida, che non centra molto con il resto: qual è il tema di Gnome che è utilizzato nelle foto presenti in questo articolo. Ve lo chiedo perché mi piace molto e vorrei utilizzarlo anche io! Ciao e grazie mille!

  6. Anche io come lejubila ho problemi a bloccare / forzare la versione da synaptic… sostanzialmente sembra che synaptic IGNORI completamente le mie indicazioni, ad ogni riavvio il gestore degli aggiornamenti mi rompe le palle e vuole che io aggiorni il pacchetto…

  7. Ah, ho parlato con imu e secondo lui il problema è che il pacchetto non proviene da un repository. Di conseguenza synaptic ignora la richiesta di bloccare / forzare la versione. Tu felipe come hai fatto?

  8. @Sandro:
    Murrina Gilouche

    @floriano:
    E chi se ne frega :)

    @Raideiin:
    Qui funziona, esattamente con la procedura descritta nella guida

  9. @Raideiin:

    Hai perfettamente ragione, i pacchetti non provengono da un repository e quindi non sono bloccabili.

    Io ho risolto installandoli dal repo beerorkid.

    La linea da aggiungere in source.list è questa
    deb http://www.beerorkid.com/compiz edgy main-edgy

    deve essere aggiunta anche la chiave
    wget http://www.beerorkid.com/compiz/quinn.key.asc -O – | sudo apt-key add –

    dopo avere aggiornato la lista dei pacchetti (sudo apt-get update) da synaptic possimo vedere che libwnck-dev, libwnck-common e libwnck18 sono aggiornabli, li marchiamo e applichiamo le modifiche.
    A questo punto se ci riloggiamo possimo verificare se tutto funziona a dovere e quindi se vogliamo marchiamo i pacchetti appena installati con “Blocca versione”.

    PS: io dopo avere aggiornato i pacchetti, per non correre inutili rischi, ho tolto il repo, dato che non so se è sicuro o meno.

  10. cmnq non si bloccano le versioni… se metti blocca versione carica synaptic e dopo vai vedere ed è ancora sbloccata…

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...