Compiz 0.3.6 è troppo instabile, ecco come tornare alla 0.3.4

Faccio subito due precisazioni:

Compiz Vs Compiz Unstable: Se vi trovate in questa situazione è perché, come me, siete curiosi di provare software sempre “fresco”. Se non volete incorrere in questo tipo di problemi non usate i repo “unstable” e restate con le versioni “stabili”!

Compiz Vs Beryl: I recenti cambiamenti di Compiz si sono propagati anche in Beryl, dato che – come saprete – alcune parti del codice di Beryl vengono periodicamente sincronizzate con Compiz. Usare Beryl non è quindi una soluzione.

Normalmente le versioni di sviluppo di Compiz sono abbastanza stabili da poter essere usate a tempo pieno, come è successo per la 0.3.4 che abbiamo tutti usato per settimane senza il minimo problema.

Purtroppo la versione di sviluppo 0.3.6 rilasciata i primi di Gennaio non rispetta questa tradizione di affidabilità ed è praticamente un incubo: ci sono bug veramente gravi che ne pregiudicano il funzionamento e compromettono l’uso stesso del PC. Penso ad esempio al bug che blocca il funzionamento di gksu, per cui ogni volta che si avvia synaptic poi si deve ricorrere alla magia nera per sbloccare il desktop…


Beh, l’unica soluzione (e le ho provate veramente tutte) è tornare a Compiz 0.3.4. Come prima cosa dobbiamo eliminare ogni traccia dell’attuale versione di Compiz:

$: sudo apt-get --purge remove compiz compiz-core compiz-extra compiz-extra-gnome compiz-extra-plugins compiz-freedesktop-extra compiz-gnome compiz-plugins gnome-compiz-manager gnome-compiz-manager-extra libgnome-compiz-manager

Alcuni di questi pacchetti potreste non averli mai installati sul vostro sistema, ma li ho trascritti comunque per completezza. Dopo aver compiuto questa operazione vi basta andare a questa pagina e scaricare il tarball in cui ho raggruppato i pacchetti per Ubuntu Edgy della stabilissima vecchia versione e, una volta scompattato, entrare nella directory creata ed installare tutti i deb presenti. Ecco le operazioni una per una:

$: tar zxf compiz-0.3.4.tar.gz
$: cd compiz-0.3.4
$: sudo dpkg -i *.deb

Questo installerà Compiz per GNOME, più GNOME Compiz Manager, ossia tutto il necessario: compiz vero e proprio, gnome-compiz-manager e compiz-tray-icon.

A questo punto dovrebbe bastare un riavvio di GNOME per avere indietro Compiz in tutto il suo splendore. Pazienza, le nuove caratteristiche ce le godremo più in là con la prossima versione stabile (si spera)

Buona wobblitudine :D

29 pensieri su “Compiz 0.3.6 è troppo instabile, ecco come tornare alla 0.3.4

  1. la prima volta che ho installato compiz-dev, un paio di settimane fa sono fuggito urlando, si comportava uguale, se non peggio di beryl. Ieri sera però mi si è sfasciato X e non ho potuto fare a meno di installarlo dato che la versione stabile è per qualche motivo “sparita” dal repo di Gandalfn. Con i nuovi driver beta NVIDIA adesso compiz va benissimo e anche beryl non si comporta malaccio. Continuo a preferire Beryl per questioni di usabilità, con beryl bisogna impostare proprio tutto, e poi manca la funzione del “cubo srotolato”, cosa che mi sono ormai abituato ad usare. Sono contento di questa versione di compiz, quindi magari provatelo con i nuovi driver… può darsi che i problemi si risolvano da solo… adesso compiz-dev è più veloce e funzionale della mia vecchia compiz stable…

  2. Io fino ad oggi, escluso, non ho avuto grossi problemi con compiz 0.3.6… ma oggi l’inspiegabile è successo… oggi ho avuto la notifica degli updates di xserver-xorg-core e compiz aggiornati alla versione 0.3.6-0gandalfn7… Aggiorno, riavvio il server x…. e dato che ho modificato la sessione per far partire automaticamente compiz al posto di metacity….. parte la musichetta di ingresso e poi si ricarica gdm… Rimetto la sessione di default… accedo senza problemi.. lancio compiz…. si riavvia credo il server x e ricompare gdm…
    Ho provato a rimettere i vecchi pacchetti xserver-xorg-core, e compiz… non va… ho provato compiz scaricato e compilato dal git oggi… nulla… ho provato con una nuova configurazione di compiz… NULLA.

    Non è più ripartito…

    Anche la versione qui postata di compiz fa riavviare X… non so più che fare :'(

  3. Hai tolto dal comando di avvio di compiz le opzioni –use-cow, –indirect-rendering e –strict-binding, come spiegato sul forum di compiz nel thread in cui è stato annunciata la release 0.3.6?
    A giudicare dal bugzilla di gentoo sembra che l’opzione –use-cow, quando non rimossa, si “mangi” la prima opzione dopo gconf, che normalmente è “decorations”.
    Qui su gentoo compiz-0.3.6 funziona meravigliosamente.

  4. io sono diventato pazzo, di colpo dopo un update non andava più niente in maniera decente, ogni nuova finestra creata non aveva il focus e si apriva dietro le altre, persino semplici form con ok-annulla.
    Da ieri ci sono stati circa 2-3 update nel repo dev di gandalf e ora posso confermare che è tutto come (meglio) di prima. Sempre riguardo i repo, gandalfn precisa che non può più mantenere edgy stable per mancanza di tempo (si sta dedicando a feisty), e quindi per edgy l’unico repo disponibile è proprio il dev.
    Preciso, se ce ne fosse bisogno, che ho una intel 945.

  5. Sì fino a oggi prima degli update andava correttamente compiz 0.3.6-0gandalfn5 la linea di comando d’avvio che usavo era “compiz.real –replace gconf decoration”…. dopo gli updates non è più partito in alcun modo.

  6. @tutti:
    Grazie per le notizie confortanti… al momento sono su una perfetta configurazione con la versione 0.3.4 e non ho tanta voglia di riprovare…

    Per quanto riguarda i crash di Ska: sappi che sto per scrivere un post per risolvere il problema. Compiz non c’entra niente!

  7. Ah :| … bene…. cioè meglio così che nn sia compiz….
    Attenderò il tuo post…

    Grazie felipe :)

  8. Non so se sono stato fortunato io… Ma io uso felicement Compiz 0.3.6 dai repo di gandalfn… E devo dire che gira meglio dello 0.3.4! BAH!

  9. anch’io avevo grossi problemi e ho recuperato i vecchi pacchetti 0.3.4gandalf in /var/cache/apt/archives/

    ero lusingato dall’annunciato supporto per kwin (che non sono riuscito a compilare…)

    penso che aspetterò per l’upgrade

  10. a me dagli ultimi aggiornamenti funziona tutto di nuovo…. un paio di giorni fa era inusabile.. schermate nere, blocchi del desktop e finestre della console totalmente trasparenti… ora si è sistemato tutto :)

  11. io uso Gentoo e ho aggiornato ieri a compiz 0.3.6 e (a parte una dovuta piccola modifica all’eseguibile /usr/bin/compiz-nvidia) non ho notato alcun problema, anzi, sembra che il nuovo compiz sia, oltre che stabile come sempre, più scattante.

  12. Io sulla ubuntu Edgy mi trovo meglio con la 0.3.6 ed effettivamente mi sembra + stabile e un pelo + scattante, però un pò + complicato da “sistemare” quando il compiz s’incarta però tutto sommato mi piace di + come sta ora.
    Poi a me dopo l’aggiornamento è bastato reinstallare i driver e tutto è tornato a posto.

  13. @tutti:
    Infatti pensavo di essere l’unico ad aver avuto problemi con la 0.3.6. In rete non si trovano lamentele o segnalazioni strane, poi però ho ricevuto due o tre conferme di malfunzionamenti e mi sono deciso a scrivere questo post.

    In ogni caso a me non funziona per niente bene, e non capisco perché, dal momento che ho anche provato azzerando ogni traccia di configurazione e reinstallando.

  14. Ciao a tutti,
    penso che per ora mi disintossicherò un pò dai desktop 3d, ho uato compiz per molto tempo, per un paio di settimane ho usato anche beryl, e ritronando a compiz ho deciso di eliminarlo per poi tornarci più in la..
    cmq volevo informare tutti che il problema di gksu dovrebbe essere legato a trailfocus, se disattivate questo plugin il problema dovrebbe essere risolto.
    a presto
    ciaooo

  15. Io non ho grossi problemi con la versione 0.3.6 sinceramente. Ovviamente dopo aggiornamento del kernel ho dovuto reinstallare il driver nvidia che non andava più questo è ovvio.
    Però compiz non mi ha dato alcun problema, anche se io lo avvio senza alcuna opzione quindi non so.

  16. Io ho avuto lo stesso problema di felipe, mi si bloccava il gksu, ma ho risolto disattivando unredirect_fullscreen_windows da gconf-editor in apps->compiz->general->screen0->options. Spero vi possa servire. Tra l’altro con gli ultimissimi aggiornamenti mi sembra si sia tutto un po’ stabilizzato.

  17. Mah… e doppio mah… come fate a dire che compiz (o beryl) o qualsiasi altro compositor siano stabili? Sono stato costretto a smettere di usarli (con grande disappunto, aggiungerei) a causa dei crash totalmente casuali del server X. Sto con Edgy/i386 e driver nvidia 9746 (tutto compilato a mano) su fx5700.
    Davvero frustrante vedere X crashare a caso, sempre con lo stesso messaggio di errore nel log, quando attivo un qualsiasi compositor: mi crasha pure col compositor di xfce o quello base di kde (quando attivate le ombre e cose del genere). A voi non è mai capitato?
    Una cosa che ho notato è che spesso il crash arriva dopo che ho usicchiato Yakuake… voglio il 3D!!!

    PS: per chi fosse interessato, il decorator per KDE incluso in compiz 0.3.6 non è niente di che. Per compilarlo bisogna andare a modificare a mano i makefile aggiungendo i path per gli header di kde (/usr/include/kde) ai CFLAGS

  18. @ziabice:
    Cacchio deve sicuramente esserci qualcosa di strambo nel tuo setup! Uso Compiz stabilmente da *mesi* e gli unici problemi che ho incontrato sono qualche piccolissima (trascurabile) mancanza di Compiz come window manager di tutti i giorni e un rallentamento nelle prestazioni con app OpenGL.

    Per il resto, esperimenti con versioni di sviluppo a parte, va tutto alla grande e mai un crash. Ho spec uguali alle tue, la mia scheda è una FX5500

  19. @felipe:
    non puoi immaginare… il primo a soffrirne sono io… putroppo attualmente per motivi di lavoro non posso permettermi una macchina instabile e quindi rimando ogni giocherellamento a data da destinarsi…
    La cosa che mi indispone è che tutto il comparto 3D funzioni benissimo, mai avuto un crash giocando (finito ieri wine + call of duty – tantissmi fps sotto windows xp).
    mi crasha a caso solo se uso attivamente le estensioni per il compositing…

  20. @ziabice:
    So solo che avevo una nVidia con un problema del genere, prima ancora di Xgl/AIGLX e Compiz, parliamo dei tempi di xcompmgr…

    Se attivavo le estensioni necessarie (composite e allowglxwithcomposite) mi si bloccava *tutto* e dovevo letteralmente resettare in stile vecchi tempi con win98.

    La scheda era una MX4000 …l’ho cambiata subito :D Ma la tua dovrebbe essere ottima, non capisco. Avrai già fatto la prova ad avviare un LiveCD tipo Sabayon o Koororaa, sì?

    Facci sapere :)

  21. mmm vedo un po’ di giocherellarci un po’ sto fine settimana usando un’altra distro… ah, aggiungo pure che i client linux di doom3 e quake4 girano alla perfezione (completati entrambi)…
    vi terrò informati…

  22. oeccato a me il 0.3.6 partiva ma improvvisamente mi rallentava tutto il computer.. cmq c’erano molte più cose, spero che risolveranno il problema..

  23. @anonimo: hai ancora il link dove hai trovato quella soluzione ?? io ho piallato una distro per quel problema li :S
    grazias

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...