Tracker per Ubuntu e Debian [repository]

Ad ogni nuova uscita di Tracker state sicuri che troverete i pacchetti aggiornati creati da Michael Biebl.

find.png
© David Vignoni e il suo Oxygen. Non è il logo di Tracker

Uso questi repository da un po’ e adesso che sembrano essere affidabili ve li voglio segnalare. Potete aggiungerli senza timore, anche perché contengono solo pacchetti per Tracker. Aggiungete queste righe al vostro /etc/apt/sources.list

Se avete Ubuntu (Dapper, Edgy, Feisty):

deb http://debs.michaelbiebl.de/ feisty main
deb-src http://debs.michaelbiebl.de/ edgy main

Ovviamente al posto di “feisty” mettete la vostra versione. Invece se avete Debian (Etch, Sarge, Sid, stable, testing, unstable):

deb http://debs.michaelbiebl.de/ unstable main
deb-src http://debs.michaelbiebl.de/ unstable main

E come sopra: cambiate “unstable” in base alla vostra versione. In ogni caso autenticateli così:

$: wget http://www.teco.edu/~biebl/biebl.asc
$: sudo apt-key add biebl.asc
$: rm biebl.asc

E infine aggiornate/installate i pacchetti:

$: sudo apt-get update
$: sudo apt-get dist-upgrade
$: sudo apt-get install libdeskbar-tracker libtrackerclient0 tracker-search-tool tracker-utils tracker

Se non volete installare mezzo GNOME come dipendenze di Tracker, ad esempio se usate KDE, potete installare solo il serivzio e le utilità da linea di comando, come segnalato tra i commenti (grazie mattions!), in questo modo:

$: sudo apt-get install tracker-utils tracker

Date un occhio ai post sotto la categoria “Tracker” se volete maggiori informazioni. Per sapere come sfruttarlo al meglio e integrarlo in GNOME vi consiglio di seguire le due guide più importanti:

Buone ricerche …ai risultati ci pensa Tracker :)

43 pensieri su “Tracker per Ubuntu e Debian [repository]

  1. Non so ancora se installare questa versione. Credo che infine mi farò tentare, ma spero proprio che sia migliore della precedente, che in fase di indicizzazione mi aveva rallentato parecchio la macchina (ok, un misero Athlon XP 2400+) con l’hard disk che sembrava non volersi fermare più. Alla fine ho ammazzato il demone e disabilitato Tracker. Sospetto che c’entri il fatto che ho 2 hard disk con 5 partizioni l’uno, ma non dovrebbe lo stesso produrre questi risultati. Sperém…

  2. Non riesco a installare i pacchetti! -_-”
    Mi ritona un codice d’errore 1 dpkg…

    Errore:
    “Spacchetto il sostituto di tracker …
    dpkg: errore processando /var/cache/apt/archives/tracker_0.5.4-1_i386.deb (–unpack):
    tentata sovrascrittura di `/usr/share/locale/de/LC_MESSAGES/tracker.mo’, che si trova anche nel pacchetto tracker-data
    Selezionato il pacchetto tracker-search-tool, che non lo era.
    Spacchetto tracker-search-tool (da …/tracker-search-tool_0.5.4-1_i386.deb) …
    Selezionato il pacchetto tracker-utils, che non lo era.
    Spacchetto tracker-utils (da …/tracker-utils_0.5.4-1_i386.deb) …
    Sono occorsi degli errori processando:
    /var/cache/apt/archives/tracker_0.5.4-1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)”

  3. @italyanker
    Credo che il pacchetto tracker-data non esista piu’, prob.t hai usato una version in cui era splittato dal tracker*.deb …
    Prova a rimuovere a mano tracker-data

    $ sudo apt-get remove tracker-data

    (potrebbe rimuovere anche la versione attuale di tracker, tanto ora la reinstallerai!:D)
    e poi nuovamente

    $ sudo apt-get install libdeskbar-tracker libtrackerclient-dev libtrackerclient0 tracker-search-tool tracker-utils tracker

    Ciao

  4. Ciao felipe. IMHO quando scrivi di un progetto devi sempre linkare il suo sito ufficiale. E’ così annoiante andare su google e cercare il nome del progetto certe volte…
    Inoltre il sito di tracker è aggiornato costantemente…
    quindi ecco quà il sito

    http://tracker-project.org

  5. Inoltre basta installare
    tracker –> per avere il demone [se lo usate come back-end con altre appplicazioni]
    tracker-utils –> per avere le command-line utility
    tracker-search-tool –> per avere l’interfaccia grafica con gnome.

    il resto viene risolto da atp

    la libreria di sviluppo litrackerclient-dev vi serve soltanto se sviluppate applicazione che richiedono la libreria di tracker

  6. @italyanker:
    I pacchetti precedenti erano creati con una policy leggermente diversa e quindi suddivisi in modo differente. Potresti disinstallare ogni traccia di tracker dal tuo sistema e poi installare nuovamente, col comando che vedi nel post.

    @mattions:
    Grazie delle segnalazioni, ora stacco il pacchetto -dev dal comando per installare, tutti gli altri servono per mettere in pratica le guide sull’integrazione di Tracker in GNOME, linkate nel post.

    Ho inserito esplicitamente le librerie perché APT ad esempio non riconosce libdeskbar-tracker come dipendenza (non lo è infatti nel senso stretto) ma noi la vogliamo lo stesso

  7. @felipe ah ecco … sei un dekbar fan!!!! :P

    Apt non sbaglia !! :P (il + delle volte :P )

    Io preferirei che sottolineassi la differenza tra le due:

    il tracker ufficiale “Desktop Agnostic” lo installi con
    apt-get install tracker tracker-utils

    E questo è tracker.

    per gli utenti gnome è possibile avere anche l’interfaccia grafica

    apt-get install tracker-search-tool

    Note: Questa si porta dietro vagonate di dipendenze di librerie di gnome

    Poi

    Integrazione con la deskbar con
    apt-get install libdeskbar-tracker

    L’integrazione con nautilus:
    Io uso i vecchi pacchetti (per edgy) reperibili sul sito:
    http://www.gnome.org/projects/tracker/documentation.html

    Non sò se su feisty è già disponibile l’integrazione out-of-the-box [dovrebbe cmq diventarlo a breve…]

  8. @mattions:
    Uhm ok, mi hai convinto. Metterò un comando per il solo tracker “desktop agnostic” allora ;)

    Spezzettare il tutto in troppi comandi non mi va, e poi è proprio per queste cose che ci sono i commenti di approfondimento :)

  9. felipe io ho tracker 0.5.3 integrato kn gnome e kn la deskbar, x mettere lo 0.5.4 basta ke disinstallo i vekki pakketti(o aggiorno?) poi l’handler x integrarlo kn la deskbar va bene quello ke stava prima?(calcola ke io ho usato l’handler aggiornato, nn il primo)

  10. @Anonimo:
    km kz scrv?!?

    Come ho scritto nel post: disinstalla il vecchio tracker e installa questo, poi per le prossime versioni si spera che non sarà più necessaria questa operazione macchinosa e basterà aggiornare.

    L’handler della deskbar per sicurezza eliminalo (potrebbe avere un nome differente) e installa questo. Per eliminarlo vai in /usr/lib/deskbar/handlers/ ed elimina qualsiasi cosa abbia il nome “tracker”. Poi installa (di nuovo) libdeskbar-tracker

  11. scusate una cosa….mi pare che tracker supporti inotify (come lo supportava anche beagle), eppure con beagle nella finestra della ricerca “magicamente” comparivano i risultati nuovi (che ne so….testi di chat appena avvenuti) mentre con tracker no……cosa devo abilitare? mi sono perso qualcosa?

  12. era meglio che mi facevo i cazzi miei e lasciavo quello… ho disintallato tacker-data so andato a installà quello nuovo e mi dice quest

    alien@linux:~$ sudo apt-get install libdeskbar-tracker libtrackerclient-dev libtrackerclient0 tracker-search-tool tracker-utils tracker
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Reading state information… Fatto
    Alcuni pacchetti non possono essere installati. Questo può voler
    dire che è stata richiesta una situazione impossibile oppure, se
    si sta usando la distribuzione “unstable”, che alcuni pacchetti
    richiesti non sono ancora stati creati o rimossi da incoming.
    Le seguenti informazioni possono aiutare a risolvere la situazione:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
    libdeskbar-tracker: Dipende: python-central (>= 0.5.8) ma 0.5.6ubuntu2 sta per essere installato
    libtrackerclient0: Dipende: libdbus-1-3 (>= 0.94) ma 0.93-0ubuntu3.1 sta per essere installato
    tracker: Dipende: libdbus-1-3 (>= 0.94) ma 0.93-0ubuntu3.1 sta per essere installato
    Dipende: libgsf-1-114 (>= 1.14.3) ma 1.14.1-2ubuntu1.1 sta per essere installato
    Dipende: libpango1.0-0 (>= 1.14.8) ma 1.14.5-0ubuntu1 sta per essere installato
    Dipende: libpng12-0 (>= 1.2.13-4) ma 1.2.8rel-5.1ubuntu0.1 sta per essere installato
    Dipende: libpoppler0c2-glib (>= 0.4.2) ma non è installabile
    Dipende: libsqlite3-0 (>= 3.3.8) ma 3.3.5-0.2 sta per essere installato
    E: Pacchetto non integro

  13. felipe questa non sarebbe ancora la versione definitiva?ahah pazzesca sta versione, non oso immaginare come sarà potente la versione definitiva, ecco perchè linux è il miglior sistema operativo, tra un aggiornamento e l’altro ci sono miglioramenti incredibili :)

  14. forse sono un po’ ot visto che si parla di pacchetti..
    se qualcuno compila tracker da svn, e nel riepilogo del configure legge che non c’è il supporto ai dati exif, o ai pdf o altro, si legga il file README, ci sono scritti i pacchetti da installare prima per abilitare il supporto ai vari file :)

  15. Felipe scusa, forse sono utonto io, ma non riesco proprio a rintracciare l’handler di eulin per la deskbar. Quando l’ho chiesto nell’altro post eulin mi ha gentilmente segnalato la possibilità di includerlo al momento della compilazione via SVN. Allora significa che è già stato integrato? Basta andare nelle preferenze della deskbar ed attivarlo? Lo chiedo perchè avevo già la versione vecchia dell’handler e non so se aggiornando dai repository mi si è aggiornato pure quello. :p

    Grazie per la pazienza!

  16. @kr0n1x:
    Prima di installare la nuova versione elimina ogni traccia di quella vecchia

    @riva.dani:
    “Basta andare nelle preferenze della deskbar ed attivarlo?”
    Yes :)

  17. @maurolinux:
    Sicuro di averlo scaricato, quel file?
    Non ho capito cosa intendevi con la seconda domanda

    @wonder:
    La funzionalità che cerchi (piacerebbe tanto anche a me!) è pianificata per una versione futura, ma la priorità è abbastanza alta quindi non preoccuparti :)

  18. si ce l’ho fatta… prima avevo installato seguendo il tuo post di qlc giorno fa tracker 0.5.4 (compilandolo) volevo sapere se per installare questo pacchettizzato dovevo eliminare il vecchio e se si come

  19. Ottimo, installato, funziona tutto. Ho impostato come hotkey per la deskbar il tasto “ricerca” del logitech mx revolution (13 tasti tutti riconosciuti sotto linux, immaginatevi che goduria con compiz X-D).
    Favoloso…
    Ogni tanto però mi mancano le funzionalità di ricerca “standard”… Spero verranno integrate! Per cercare cose tipo “Video aggiunti di recente” o “Video sopra i 600MB” devo ancora utilizzare gnome-search-tool -.-

  20. Non so se e normale ma a me trackerd ciuccia il 50% di CPU al minimo ed e lentissimo a trovare risultati… E normale? No vero….

  21. Soddisfatto di Tracker ma…
    dove salva il database Tracker?
    Intendo nella root o nella home? Qualcuno sa il percorso??

  22. Anche a me sta andando da circa 2 giorni..mangia 50% di CPU e non capisco se è normale, ovvero che si aggiorna costantemente o cosa…spero non accumuli dati su dati intasando l’HD..per questo chiedevo se salva il database solo in home/utente/.Trasker o va anche in /

    Grazie,

    tuttavia ho notato una certa lentezza nel fare la ricerca al posto di Gnome-search-tool

  23. è momentaneo il down di tutti i siti che ospitano i repository per installare tracker via apt-get?
    Ho provato per tutta la sera e li ho trovati sempre down. Non avendo trovato alcun riferimento in giro per internet, immagino che così sia ma nel dubbio chiedo ugualmente.

    Perdonatemi per la domanda forse inopportuna!

  24. il tempo ha provveduto a rispondermi.Com’era ovvio che fosse, è tornato tutto online nel giro di alcune ore.

  25. felipe ho seguito la guida ma tracker si ciuccia quasi costantemente il 100% della cpu, da ormai più di un giorno, nn credo sia normale ho un HD da 60GB e ho messo come percorso da indicizzare “/” cosi che indicizzi tutto compresa la partizione windows.
    la configurazione comprende: cpu centrino 1,5GHz, ram 512, video ati 9200, compiz abilitato.
    ho disinstallato tutto se qualcuno conosce una soluzione o semplicemente sa perchè avviene questo, gli sarei molto grato

  26. @ Ferny

    Sapresti dirmi come configurare correttamente il mio Logitech MX Revolution su Ubuntu (Feisty)? Ho provato diverse guide ma il risultato è stato disastroso. Grazie anticipatamente.

  27. @KaMZaTa
    apt-get install xserver-xorg-input-evdev
    Poi aggiungi questo in /etc/X11/xorg.conf sotto al mouse normale (controlla che le aperte e chiuse virgolette restino quelle semplici quando fai copia e incolla!)
    Section “InputDevice”
    Identifier “mx”
    Driver “evdev”
    Option “Name” “Logitech USB Receiver”
    Option “CorePointer”
    Option “Buttons” “12”
    Option “WHEELRelativeAxisButtons” “4 5”
    EndSection

    Nella sezione Server Layout aggiungi:

    InputDevice “mx” “SendCoreEvents”

    Tutto qua :D
    Per mappare il tasto Cerca: xmodmap -e “keycode 144 = XF86Search”
    Per configurare il tasto centrale: http://goron.de/~froese/revoco/

  28. Perdonate un neofita ma i pacchetti proprio non ci sono… ho aggiunto gli indirizzi e cambiato la distro (etch)…

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...