Aggiornata la guida agli “Effetti Desktop” per Ubuntu Feisty

Giusto una segnalazione a chi fosse interessato: ho aggiornato e semplificato parecchio la guida “Ubuntu Feisty + nVidia + Compiz“, talmente semplificata che al momento è praticamente inutile :D

pollycoke-thu.png

Col tempo provvederò ad aggiungervi sezioni avanzate, tipo segnalazioni di repository esterni per versioni di Compiz sempre aggiornate, plugin extra provenienti dal progetto Beryl che adesso fa di nuovo ufficialmente parte integrante di Compiz ecc ecc.

Effusioni generiche. Non cambiate canale

19 pensieri su “Aggiornata la guida agli “Effetti Desktop” per Ubuntu Feisty

  1. ho come l’impressione hce la notorietà di questa fortunata serie di guide calerà spaventosamente tra pochi giorni :P

    felipe: travati un’altra cosa bella da usare per desktop così magari introduci una nuova serie fortunata

  2. Grande Felipe, continua così… aspetto avidamente una guida per installare compiz 0.5 e gnome-compiz-manager-extra che pur apparendo nella lista dei pacchetti non ne vuol sapere di installarsi!!

  3. Da me non compiz non funziona.
    Ho anche creato un nuovo utente, così da avere tutte le impostazioni azzerate.
    Il window manager non viene avviato (ma alcuni effetti si vedono) :-(

  4. anch’io ho problemi con compiz (intel i850 driver) : mi appare una schermata biancastra e nient’altro. Se però cerco di switchare tra finestre o usare l’effetto “exposé” (ctrl+alt+freccia su) intravedo qualcosa…. suggerimenti?

  5. Mannaggia.
    Aveva funzionato tutto benissimo sul mio desktop con tanto di Ati 9250, aggiornato velocemente a Feisty con Compiz up & running senza problemi…

    e invece sul portatile con una semplicissima intel, che aveva fatto andare compiz al volo sotto edgy, adesso è tutto alle quaglie: se avvio desktop-effects ho questi errori:

    nvidia hardware not available
    gtk-window-decorator: Could not acquire decoration manager selection on screen 0 display “:0.0”
    /usr/bin/compiz.real: GLX_EXT_texture_from_pixmap is not supported by direct rendering context, trying indirect rendering context instead
    /usr/bin/compiz.real: No stencil buffer. Clipping of transformed windows is not going to be correct when screen is transformed.
    inotify_add_watch: No such file or directory
    Segmentation fault (core dumped)
    Avviso del window manager: Il valore «» nel database di configurazione non è valido per la scorciatoia «toggle_shaded»

    (…tra l’altro — ma che c’entra l’nvidia hardware?!? — xorg usa il driver intel i810…)

    se avvio da command line dando anche –indirect-rendering almeno AWN riesco a farlo andare bene (se no… striscia nera a fondo schermo e niente icone) ma wobbling e cubo, niente da fare. aiut :/

  6. per la cronaca, ho risolto:

    – tolto desktop-effects
    – tolto (almeno per ora) anche compiz-tray-icon
    – sistemato un po’ di disordine nei pacchetti installati (avevo ancora pacchetti edgy di compiz unstable….)
    – reinstallati tutti i pacchetti ufficiali feisty

    e ora… cuba tutto! :D

  7. @michelefrost

    come fai a vedere se ci sono installati pacchetti edgy di compiz unstable?
    io ho il tuo stesso problema, dall’aggiornamento a feisty non riesco più ad utilizzare i driver nvidia e il desktop effects non ne vuole sapere di partire. Proverò a rimuovere i pacchetti *compiz* e vediamo che succede.

  8. inoltre: sul pannello di gestione dei restricted drivers, non è presente il driver nvidia. non posso quindi abilitarlo o disabilitarlo. ma si andava tanto bene con edgy.. almeno uno sapeva dove andare a mettere le mani! adesso invede…

  9. ci sei riuscito?
    io desktop-effects l’ho proprio eliminato, ho sistemato i pacchetti compiz da synaptic, togliendo tutto e rimettendo solo quelli “giusti”, e funzia. Però non ho mai avuto problemi col driver (Ati, non Nvidia…) quindi su quello non ti posso aiutare… magari nella chat di pollycoke?

  10. io ho una ati 9250, ma sotto ubuntu quando cerco di installare i driver scrivendo:

    fireb86@fireb86-desktop:~/Desktop$ chmod +x a.run
    fireb86@fireb86-desktop:~/Desktop$ LANG=C LC_ALL=C ./a.run –buildpkg Ubuntu/dapper

    mi parte la proceduta:

    Creating directory fglrx-install
    Verifying archive integrity… All good.
    Uncompressing ATI Proprietary Linux Driver-8.24.8…………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………..
    -e

    ma alla fine mi da questo errore:

    ==================================================
    -e ATI Technologies Linux Driver Installer/Packager
    -e ==================================================
    ./ati-installer.sh: 97: Syntax error: Bad substitution
    Removing temporary directory: fglrx-install

    qualcuno sa per caso il motivo?? magari devo installare qualche repository particolare?? vi prego trovatemi la causa perchè è uno scempio far girare ubuntu a 1024×768 su un 19 pollici…e poi gli effetti video che possiede!!

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...