Novità per Clearlooks

Clearlooks è lo stile (engine, tema, come preferite) predefinito di GNOME, sia per i controlli GTK+ che per il decoratore delle finestre Metacity. Abbiamo una diapositiva:

clearlooks-05_1.png

Lo stile classico di Clearlooks è stato sviluppato ormai anni or sono grazie a vari input di aziende come Red Hat (deriva dal vecchio BlueCurve) e i consigli di tanti utenti, sviluppatori e qualche blogger come Eugenia. L’aspetto – molto pulito – è ormai un po’ superato…


Proprio ultimamente c’è un gran fervore attorno a Clearlooks, sia a livello di prestazioni migliorate che a livello di gradevolezza estetica, sono state perfezionate alcune varianti alternative (Glossy), rimosso ciò che andava rimosso (Inverted) e implementato ciò che in molti (me compreso) si auguravano che venisse implementato. Ecco una schermata della nuova variante Gummy:

gummy-thu.png

Gummy è ufficialmente in mio nuovo stile predefinito! Come vedete, l’aspetto è leggermente evocativo dell’idea di gommosità, ma senza scadere nel cattivo gusto. O almeno l’intenzione credo fosse quella :D

Non è ancora perfetto ma mi piace molto. Complimenti ad Andrea Cimitan, lo sviluppatore (italiano) che sta da poco collaborando a Clearlooks, come ho subito sperato che facesse da quando Thomas Wood fece l’appello (cfr. “I temi di GNOME hanno bisogno di un direttore artistico“). Questo Clearlooks è meno giocattoloso di Murrine (stile da me usato e consigliato in passato), ma è indubbiamente più bello della versione “liscia” Classic.

Se volete installare queste nuove versioni di Clearlooks potete scaricare il codice direttamente da svn:

$: svn co http://svn.gnome.org/svn/gtk-engines/trunk gtk2-engines

…e compilarlo seguendo il metodo che più vi aggrada, consiglio la lettura dei post catalogati come “Compilare con Debian (e Ubuntu)“. Per i più pigri potrei preparare un pacchetto .deb “da combattimento”… chiedete se vi serve.

PS: Cimi non sapevo che avessi un blog fino ad oggi, l’ho scoperto perché è stato aggregato a Planet GNOME Italia. Doppi complimenti quindi, anche se non siamo più in contatto, continuo a supportarti come ho fatto da sempre …quando ci vuole ci vuole.

Buono GNOME a tutti

42 pensieri su “Novità per Clearlooks

  1. @Felipe: Ti invito a tal proposito (Blog di Cimi) a leggere alcune riflessioni fatte su mono … tracker e Beagle …

  2. Bello il nuovo tema!
    Mi piace!
    Devo ammettere che ho sempre trovato troppo “retrò” il clearlooks di Gnome.
    Già lo Human di Ubuntu è più bello.. il Glossy mi piace proprio. Dopo aver provato Feisty Alpha 3 non riuscivo più a farne a meno!

    Coi look predefiniti che si vedono in qualche screenshot per la rete resta comunque, almeno per quanto mi riguarda, un alone di “vecchio” e “pesante” su Gnome :/

    Molto più fresco e dinamico uno Gnome versione Ubuntu..

  3. il tema che hai recensito è molto bello e penso proprio che lo installerò… ma… posso chiederti cosa è successo tra te e Cimi? Tu gli fai pubblicità (meritata, per carità) e lui …leggi il suo blog ;)

  4. aldila’ del tema di Gnome (io uso kde)… ma che font usi per le icone del tuo desktop?
    looks beautiful indeed…

    ciao

  5. [troll mode]

    gh gh
    [/troll mode]

    Scherzi a parte, clearlooks e le sue varianti sono veramente un capolavoro, davvero complimenti a tutti gli sviuppatori.

  6. @felipe:
    Non noto particolare “gommosità”, parli dei contorni arrotondati di finestre e pulsanti? saresti così gentile da fare uno screenshot zoomato (a buona risoluzione ;D ) di una finestra per vederlo meglio?

  7. @3 @ bigshot:
    Su mono la pensiamo in modo TOTALMENTE diverso, ma non c’è niente di male in questo, è giusto pensarla in modo diverso perchè è un argomento importante che non va banalizzato.
    Comunque non mi riferisco in particolare a felipe con le critiche sulla ignoranza e superficialità sulle licenze, lui almeno molte cose se le è lette pur pensandola diversamente.
    Mi riferisco a chi non lo installa “a priori”, credendo in qualche cospirazione o problemi di licenze (cazzate ndR).

    @felipe:
    Di inverted è stato cancellato il metatheme, tutto il resto dall’engine ai temi gtk e metacity sono rimasti. Non è la mia follia dal punto di vista dei gusti ma piace a tantissima gente, sopratutto per il suo look flat che si integra bene con altri wm come openbox etc etc, molto diffusi.
    Comunque sono d’accordo che gummy e glossy siano diecimila volte meglio :)

    @Jaba: non per spam ma sul mio blog c’è uno screenshot completo, lì si vedono tutti i widget

  8. molto bello, lo proverò, per ora sto usando murrine per la sua velocità, è veramente ottimo, speriamo che questo gummy sia almeno al pari di murrine

    ciao ciao

  9. amministrazione–>qualcosa dei caratteri :D

    da li modifichi , scusa se non sono preciso ma sono a lavoro su winmerda e non ho il pannello sottomano T_T

  10. Anche a me piacerebbe avere il pacchetto… Ho provato (per la prima volta) a compilare. Leggendo le tue guide ho capito più o meno come funzionano make, make install e checkinstall, ma dopo aver dato svn co [indirizzo] non so proprio più cosa fare… Dove ha scaricato e cosa?

  11. Aggiornamento: sono andato avanti, ho usato autogen.sh (spero di aver fatto bene) poi make e make install. Però non vedo nessun nuovo tema… :(

  12. @ Felipe

    non so forse sono talmente pigro che non sono riuscito a capire cosa leggere x pacchettizzare il tema e perciò non so come fare….

    per cui adesso ti lancio il seguente ultimatum minaccia:

    o posti un deb. bello e pronto o mi indirizzi bene su come fare a pacchettizzare con svn entro un’ora da questo momento oppure giuro e ho le palle x farlo non leggerò + il tuo blog….ricorda sono dotato di mouse e non ho paura ad usarlo :) ;)

  13. @felipe: cosa hai installato di -dev per compilare i gtk-engines?
    io continuo ad avere:
    checking for THEME_ENGINE… configure: error: Package requirements (gtk+-2.0 >= 2.0.0 gdk-pixbuf-2.0 >= 2.0.0 gtk-engines-2 >= 2.9.0 ) were not met:

    No package ‘gtk-engines-2’ found

  14. @ lupo (e quindi felipe)

    IDEM!
    Anchio non ho ancora capito come pacchettizzarlo da svn!
    Sembra bello glossy! Clearlooks non mè mai piaciuto… uso il classico Human però in blu (quindi molto simile a Glossy!)

  15. @ Twiggy
    Grazie. Ma…..
    Tentativo di installare gtk2-engines_2.11.0-1_i386.deb
    Error: Una versione più recente è già installata

    Tentativo di installare gnome-themes_2.19.3-0_i386.deb
    Spacchetto il rimpiazzo di gnome-themes …
    dpkg: errore processando /home/pippo/gnome-themes_2.19.3-0_i386.deb (–install):
    tentata sovrascrittura di `/usr/share/icons/HighContrastInverse/index.theme’, che si trova anche nel pacchetto gnome-accessibility-themes
    dpkg-deb: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)

    ????? :(

  16. @ Twiggy
    Grazie per la dritta.
    Scusa se ne approfitto ho un dubbio:
    ma devo installare anche
    gtk2-engines_2.11.0-1_i386.deb
    anche se mi dice che ho già una versione
    più recente sul sistema.
    Oppure basta installare solo
    gnome-themes_2.19.3-0_i386.deb?
    Sono su Feisty.
    Grazie. Non vorrei creare casini al sistema.

  17. Si installalo… Anche a me dice che c’è una versione più recente ma è solo una bugia! :P Mi spiego il pacchetto installato ha un numero di versione scritto tipo così “1:2.xx.x.ecc” e a quanto sembra lo rileva come più recente ma in realtà è più recente il pacchetto da me creato! ;) Dopo averlo installato da Synaptic blocchi il pacchetto a questa versione e non avrai più avvisi! ;)

  18. Sarà che sono arrivato tardi, ma entrambi i link per scaricare il pacchetto deb mi portano ad un sito che chiede d’iscriversi _a pagamento_ per poterli scaricare. Mi pare davvero strano come fatto.

    Non c’è altro modo per ottenere quei pacchetti?

    Grazie in anticipo!

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...