Deluge 0.5.1 provato e impacchettato [pollyrepo]

Proprio quando pensavo che non sarebbero più arrivate novità interessanti da questo progetto che mi ha entusiasmato da subito (cfr “Deluge, client bittorrent in PyGTK: quanto ti ho aspettato!“)…

 

Deluge è un client per il protocollo Bittorrent, quindi parliamo di P2P (ma stavolta non c’entra niente con Licio Gelli) . La versione 0.5.1 di Deluge supporta finalmente alcune funzionalità tanto richieste, e quasi necessarie, come la encryption, eccole in dettaglio:

  • Peer Exchange
  • Encryption
  • UPnP + NATPMP
  • Improved user interface
  • Redesigned preferences dialog
  • Startup and shutdown bugs fixed

Nel mio repository dunque trovate già Deluge 0.5.1 per Ubuntu Feisty. Ho creato il pacchetto partendo dalla directory debian dei sorgenti ubuntizzati ufficiali di deluge per Ubuntu Feisty, quindi – nonostante il solito avviso che questo non è software ufficialmente supportato da Ubuntu – potete andare relativamente sicuri e installare: è compatibile al 100% con Ubuntu e giuro che non ho fatto altre modifiche, hahaha -.-

Beh, sono contento che il progetto Deluge vada avanti, e credo che meriti di essere pubblicizzato e conosciuto. Diffondete ;)


PS: per maggiori informazioni su Deluge visitate il sito ufficiale o scorrete i miei vecchi post catalogati come “
Deluge

52 pensieri su “Deluge 0.5.1 provato e impacchettato [pollyrepo]

  1. Il problema è che Delunge praticamente lo uso solo per tirare giù le ISO di Ubuntu… Che altro ci si trova (di legale) in bittorrent??

  2. ho installato il nuovo deluge dai pollyrepo ma da terminale ho questo errore :
    ………..
    ImportError: No module named deluge

    La versione precedente era funzionante al 100%

  3. quoto effe!

    non scarico solo le iso di ubuntu, ma anche di altre distribuzioni…però l’idea è quella!

    ciao

  4. @risidoro:
    @deccab189:
    Uhm, a me succedeva la stessa cosa con un vecchio pacchetto… appena posso do un occhiata. In ogni caso qui funziona, aspetto di sentire altre testimonianze

  5. Il problema è che Delunge praticamente lo uso solo per tirare giù le ISO di Ubuntu… Che altro ci si trova (di legale) in bittorrent??

    ma dai , fai una piccola ricerca su google , cerca tracker

  6. @felipe && tutti: PROBLEMA RISOLTO. ‘Ho purgato’ il pacchetto deluge e rimosso la cartella dei file di configurazione ~/.config/deluge

    Poi ho reinstallato e adesso funge tutto a meraviglia!

    Grazie Felì

  7. dovete cancellare il file di configurazione perchè tutto il menù preferenze è stato riscritto. solo nn mi ricordo dove stà…

  8. […] installare: è compatibile al 100% con Ubuntu e giuro che non ho fatto altre modifiche, hahaha -.- […]

    ahahahahah che mattacchione che sei ahahaah :)

  9. @felipe: visto che l’aggiornamento diretto sembra dare problemi ad alcuni, puoi aggiornare il post dicendo di rimuovere la cartella ~/.config/deluge in caso di problemi?

  10. Installato ma non funziona.
    Ecco cosa succede:
    aldo@feisty:~$ deluge
    no existing Deluge session
    Starting new Deluge session...
    deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG value: 1
    Applying preferences
    Starting DHT...
    /var/lib/python-support/python2.5/deluge/core.py:713: DeprecationWarning: integer argument expected, got float
    PREF_FUNCTIONS[pref](self.get_pref(pref))
    Traceback (most recent call last):
    File "/usr/bin/deluge", line 83, in
    start_deluge()
    File "/usr/bin/deluge", line 57, in start_deluge
    interface = deluge.interface.DelugeGTK()
    File "/var/lib/python-support/python2.5/deluge/interface.py", line 47, in __init__
    '%s %s'%(common.PROGRAM_NAME, common.PROGRAM_VERSION), common.CONFIG_DIR)
    File "/var/lib/python-support/python2.5/deluge/core.py", line 213, in __init__
    self.state = pickle.load(pkl_file)
    File "/usr/lib/python2.5/pickle.py", line 1370, in load
    return Unpickler(file).load()
    File "/usr/lib/python2.5/pickle.py", line 858, in load
    dispatch[key](self)
    File "/usr/lib/python2.5/pickle.py", line 1069, in load_inst
    klass = self.find_class(module, name)
    File "/usr/lib/python2.5/pickle.py", line 1124, in find_class
    __import__(module)
    ImportError: No module named deluge

  11. @Aldo:
    A quanto pare è un problema dovuto ai cambiamenti al sistema di preferenze/configurazione di Deluge, segui le indicazioni date da risidoro nell’ottavo commento e facci sapere.

  12. So che è OT, ma vi straconsiglio di provare KTorrent 2.2b1 (uscito da non molto), è davvero eccellente. Gli manca un tantino così por giungere a livelli di uTorrent. Ora direte “peccato che sia per KDE”. Beh… ne riparliamo a ottobre! :>

  13. O.T.: ahh, che sensazione di pace e tranquillità! Dopo cena dò un’ occhiata al piccì e trovo un bel post di Felipe che stuzzica la mia curiosità e invoglia a scaricare un nuovo pacchettino, a volte è così confortante la normalità che poi quando qualcosa cambia non ti ritrovi più, e ti senti smarrito…. da parte di tutti quelli come me che si sono sentiti un po’ abbandonati ultimamente: ben tornato Felipe e scusaci per aver potuto solo dubitare!

  14. sembra interessante, magari aspetto l’aggiornamento ufficiale sperando che non faccia saltare il programma come tutti gli altri aggiornamenti che ho provato a fare sulla mia gutsy ;)

  15. @loopback: a nome del team di Kiss Me Lorena, grazie per la segnalazione (non osavo farlo io perché non mi piace la pubblicità nei commenti dei blog altrui…)

  16. @coloro che hanno riscontrato problemi nel aggiornare deluge
    scrivete questo in terminale:

    rm ~/.config/deluge/persistent.state

    e deluge ripartirà come una volta. Ho riscontrato anche io quest problemi.

  17. O mio dio hanno introdotto l’encryption!!!!! Questa si che è una novità.. raga finalmente deluge è un progetto con le pa**e che può cominciare a dare le scarpe a ktorrent.

  18. transmission è probabilmente il più leggero di tutti, l’unico problema è che è bannato da parecchi tracker perché spesso (a seconda del tracker) sbaglia a interpretare gli announce.
    io mi trovo benissimo con tf-b4rt (http://tf-b4rt.berlios.de/), messo su un k6 300 insieme a lighttpd, php5 e mysql: è un’interfaccia web per più client, per ogni torrent si può scegliere il client con cui scaricarlo (ne supporta diversi tra quelli a linea di comando), a patto ovviamente che sia installato. :D

  19. @effe
    prova a scaricarci gli album intervi sotto licenza Creative common che trovi su jamendo per esempio

  20. un paio di domandine…. come numero di fonti gira bene? la vecchia versione non trovava tutto… e sui torrent più rari è una bella grana…

    adesso tiene in memoria ciò che si sta scaricando alla chiusura? ogni volta mi toccava ricaricare i file

  21. anche questa versione si è rivelata una delusione come la precedente.
    peccato.. devo continuare a usare ktorrent :(

  22. Quello che non mi piace è il tasto “Elimina i Torrent completati”, tra l’altro senza nemmeno una richiesta di conferma prima di farlo.
    Inoltre lo trovo contrario allo spirito p2p smettere di condividere un file appena scaricato.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...