Rhythmbox 0.11.1 impacchettato per Ubuntu Feisty [pollyrepo]

Ultimamente nei repo di Gutsy c’è stata un bel po’ di attività, ma non si è visto niente di goloso da impacchettare, a parte il fatto che il maintainer di Compiz ha fatto la cosa giusta e ha (quasi) adottato lo script wrapper dei pacchetti di Treviño ;)

rb11.jpg
“Swallow me into your bed, with glimpses of your thighs…”

Poco fa è stato importato anche Rhythmobx all’ultimissima versione 0.11.1 (ad essere sinceri non è ancora stato fatto l’upload, ma i pacchetti sono comunque disponibili). Beh non ho perso tempo e ho subito pollycokizzato. Se avete abilitato il mio repository ci trovate già il pacchetto aggiornato :>

I cambiamenti di questa versione:

    - make gapless/xfade playback and visualisations work together better
    - handle lastfm:// URIs
    - make Magnatune/Jamendo loading intro saner on small screens
    - fix last.fm streaming
    - allow the user of Magnatune gift cards
    - do iPod DB saving in the background, not blocking the UI
    - vastly reduce the Jamendo plugin's memory usage
    - add support for MTP audio players
    - clean up the playback preferences UI
    - update play count, rating and last played on iPods
    - add support for multiple lyrics sites, and allow editing of lyrics

Niente di assolutamente rivoluzionario, come potete vedere, ma tanti piccoli dettagli che non potete ignorare :D

38 pensieri su “Rhythmbox 0.11.1 impacchettato per Ubuntu Feisty [pollyrepo]

  1. quando cambi ‘sta schifezza e passi ad Amarok? :)
    Ma soprattutto, quando mi spieghi perchè Amarok non ti piace? guarda che sarà la 10a-11a volta che te lo chiedo! Eddai felipe mi hai promesso un post una volta! Fai il buono!
    Saluti!

  2. …niente di rivoluzionario?

    “make gapless/xfade playback […] work together better”

    era ora! Finalmente! Non vedo l’ora di provarlo
    Finalmente posso ascoltare le compilation e i concerti dal vivo come si è sempre fatto con lo stereo di casa ancora dai tempi dei giradischi…
    :)
    Maurizio

  3. quando tento di ascoltare le radio su LastFm ottengo il seguente errore:”Impossibile avviare la riproduzione. Risorsa non travata” Anche a voi accade? Come posso rimediare?

  4. La modifica più utile per me è il profiling fatto sul plugin di jamendo. Nella versione precedente era sufficiente solo scaricare la lista da Jamendo che Rhythmbox si appropriava di 200 mega di memoria.

  5. @andreaspecial
    Amarok usa le librerie grafiche qt, quelle per kde…Normalmente chi usa Gnome è un pò come un utente Mac, adora avere tutti i programmi perfettamente integrati nel tema di sistema del desktop…è una cosa che gli utenti kde non conoscono.
    Sicuramente amarok ha qualche funzionalità in più, ma lo stile e il gusto di avere un ambiente desktop coerente è decisamente una cosa irrinunciabile.
    Fermo restando che definire una schifezza Rhythmbox significa essere quantomeno “a senso unico”.
    Open your Mind!

  6. “add support for multiple lyrics sites, and allow editing of lyrics”
    Era ora!!!
    Spero che anche Amarok faccia una cosa simile… per ora funzionano solo un sito alla volta :(
    [ma per Amarok mi sa che dipende da come sono fatti gli script…]

  7. Mi scuso per il doppio commento.

    @ Anonimo (10)
    Non significa niente quello che dici. Esistono ovviamente utenti KDE che tengono anche loro all’integrazione delle loro applicazioni con il Tema del desktop.

    Per quanto riguarda Rithmbox e’ un bel programma. Anche se manca un po’ di customizzabilita’, che e’ una cosa che invece gli utenti KDE amano alla follia [e che Gnome ha scoperto da poco direi, ma non lo dico altrimenti mi fucilate ^_- ].

  8. Magari chiedo troppo, ma non è che potresti impacchettare robe anche per edgy, per noi plebei che non riusciamo a fare l’aggiornamento?? Te ne sarei infinitamente grato…

  9. [i]- add support for MTP audio players[/i]

    Il mio Samsung T9 (divino!) mi concede la possibilità di scegliere, tramite aggiornamenti del firmware, se utilizzare l’MTP o l’UMS. Però uscito di fabbrica era MTP, e ricordo la fatica anche solo per riuscire a trasferire i file per aggiornare il fw… Considerando che poi molti lettori sono solo MTP, questo è un bel passo avanti, anche se scoraggerei il più possibile l’uso di questo protocollo, decisamente pessimo!

  10. contentissimo per l’ultima voce, pero vedo che last.fm ancora non va

    e sopratutto, ancora non hanno risolto quello stupido bug nel ridimensionamento dello spazio occupato dalle voci di descrizione dei brani!!

  11. a me con il crossfading attivato continua a crashare dopo 2 o 3 canzoni….
    sembra invece risolto il problema dell’importazione delle canzoni: dopo una serie di importazioni multiple non mi ha ancora dato nessun brano “sconosciuto”

  12. Quando riusciranno a gestire la compatibilità con la musica condivisa con iTunes7 ?

    so che è colpa di Apple che ha crittografato il traffico … però mi sarebbe comodo assai ;)

  13. Per felipe, domanda semiseria.

    Premessa
    Senza nulla togliere al tuo lavoro, fatto nel tempo libero e apprezzato da molti.

    Ma….

    Per quale motivo, continui a “impacchettare” programmi che comunque sono presenti senza troppe variazioni nei repo stessi? Ok, la versione nuova fa figo…ma… Onestamente preferirei vedere “impacchettati” programmi che non sono presenti nei repo ufficiali, cosi’ sarebbe un vero aiuto per tutta la comunita’. Spero, che la tua risposta non sia solo che stai “impacchettando” mezzo repo della versione successiva, perche’ sarebbe assurdo, prematuro e anche ….ma si diciamolo…. “pericoloso”.

    Per il resto complimenti.

  14. @felipe
    Ho impacchettato l’ultima versione di libmtp (0.1.5) dai repo Gutsy seguendo la tua guida. Questo perché alcuni lettori (il mio) non funzionano con le versioni precedenti. Se lo ritieni utili, aggiungili ai tuoi repo altrimenti chi ne ha bisogno li scarica da qui.

    http://www.unbase.com/n/5006398243

  15. Io ho dovuto eliminare il repository di pollycoke perché quest’ultimo prevede un aggiornamento di Gimp che va a sostituirsi alla versione 2.2 con la quale sono abituato a lavorare… A dire il vero l’unica cosa che mi manca della vecchia versione sono gli Script-fu :(

  16. Felipe… se davvero nella tua playlist di Rhythmbox c’e’ Isn’t Anything they MBV… mi prostro adorante…

    Shoegazer for life…

  17. forse si dovrebbe far sapere agli sviluppatori che Rhythmbox 0.11.1 ciuccia un sacco di CPU all’avvio e anche durante l’utilizzo… dove si può fare?

  18. si in effetti… niente da dire sull’integrazione desktop e l’ottimizzazione delle risorse…
    di sicuro Felipe fa bene a impacchettare le versioni più recenti se ci sono miglioramenti…
    però IMHO Rhythmbox fa davvero schifo. Ha una pessima gestione della libreria, non funziona(ava) last.fm, poche funzioni e zero customizzabilità ..
    e, sempre IMHO, al momento non c’è niente in GTK a livello di amarok: il fatto che sia in qt x me significa solo un tempo di avvio leggeremente più alto (~10 sec), l’integrazione in gnome (anche estetica) è ottima.

  19. @ cimi

    ho testato e ti ho risposto (sono un bug hunter gnome eheh). NN mi sembra un bug poichè con un tema chiaro si legge tutto

  20. ed io ti ho ririsposto.
    Resta un bug perchè non si può fare un codice che funziona solo con un tema. Hanno fatto un workaround grezzo non compatibile con le gtk se hanno messo colori fissi

  21. io uso un tema scuro (murrina-blu profondo) e non ho problemi di visualizzazione in RB, anche se per la verità non ho capito molto bene di che problema si tratti. Restano i crash con il crossfading attivato, quelli sono un po’ una rottura

  22. boh, io ho notato che quando lo attivo pur funzionando (il crossfading lo fa egregiamente) mi manda in crash il programma che si chiude per gli affari suoi ogni 3 o 4 canzoni, cosa che non fa quando lo disattivo. può darsi che magari sia un problema di settaggio, tu come lo hai impostato? (se si può sapere)

  23. questa versione ha un bug gravissimo: quando riproduco gli ogg, sento un fruscio, dei gracchiamenti… insomma è impossibile usare file ogg, e tutta la mia libreria è in ogg :,-(

  24. Torno a chidere se qualcuno di voi è riuscito a far andare Rhythmobx con le radio mms (tipo radio 105 per intenderci). A me va con amarok ma non con Rhythmobx.
    Neanche con questa pollycocke-version 8-)

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...